Importing your 3d model

Importing your 3d model



Importing your 3D model

To import your 3d model into the frontline.io 3D Studio:
* frontline.io 3D Studio supports FBX, OBJ, GLTF2, STL, PLY, 3MF file types for 3D models.

* If don't have the correct file type, use the Converting CAD Files to Frontline Models article to proceed.

1. Drag your 3d model into Unity's Project Tab, or go to Assets > Import New Asset under the top menu




2. Create a new scene under File > New Scene and select Basic

3. Drag the 3d model into your scene, make sure its transform values are zero when selecting the model:




4. Right click on your 3d model in the Hierarchy tab, select LLS > Set Frontline Scene




5. Select a location to save your scene.

You can now press Play (under Edit > Play) and interact with your 3D model.

You can now create your first procedure with your model.

Troubleshooting

Materials and Colors are not editable
Cause: Materials are not extracted from the FBX File.

1. In the project window, select your FBX file
2. When selected, in the "Materials" tab, click "Extract Materials"



3. Select a location in your project to extract the materials into (into a "Materials" folder is preferred)
4. Select the model in scene.
5. Open the material in the inspector. it should now be editable.